Can't use program mode on X-T1 with 18mm f2 lens

Discussion in 'Fuji X-Mount Cameras' started by theoldsmithy, Dec 3, 2017.

  1. theoldsmithy

    theoldsmithy FujiXspot Regular

    107
    Feb 4, 2013
    Herefordshire, England
    Martin Connolly
    Hi all,
    I've just got an 18mm f2 lens for my X-T1. It works fine setting the aperture on the lens, but when I set all the dials to 'A', the front dial does not change the aperture setting as it does for the 16-50 lens. Shouldn’t it do that?
     
    Last edited: Dec 3, 2017
  2. Mike G

    Mike G FujiXspot Top Veteran Subscribing Member

    604
    Oct 7, 2016
    London
    Mike Gorman
    No it shouldn’t it has an aperture ring!
     
  3. Anthony Wilkins

    Anthony Wilkins FujiXspot Rookie

    21
    Jun 2, 2016
    Anthony Wilkins
    You have to set the front ring to ‘a’ as well for program mode or to have the camera control the aperture in any mode.
     
  4. theoldsmithy

    theoldsmithy FujiXspot Regular

    107
    Feb 4, 2013
    Herefordshire, England
    Martin Connolly
    Yeah I have the front ring set to A. Is there no program shift?
     
  5. Anthony Wilkins

    Anthony Wilkins FujiXspot Rookie

    21
    Jun 2, 2016
    Anthony Wilkins
    Not a mode I use much but my understanding that you can use the rear dial. ISO may have to be set to a set value and not auto but I can’t recall for sure.

    And my experience comes from the XP1and X100F so the XT1 may be different.
     
  6. Anthony Wilkins

    Anthony Wilkins FujiXspot Rookie

    21
    Jun 2, 2016
    Anthony Wilkins
  7. theoldsmithy

    theoldsmithy FujiXspot Regular

    107
    Feb 4, 2013
    Herefordshire, England
    Martin Connolly