Lightroom 4.4 requires Windows 7 or Vista. Ugh. Pbblth.

Discussion in 'Open Discussion' started by carlb, Apr 10, 2013.

  1. carlb

    carlb FujiXspot Veteran

    267
    Feb 6, 2013
    twin cities, minnesota
    Carl
    I was all set to try out Lightroom 4.4 for raw conversion of X20 and X-E1 files. Downloaded the upgrade (an hour and some change), unpacked the files, and started the install.

    "Lightroom 4 requires Vista or Windows 7. Install cancelled."

    Glad I chose the "Try" option for the free 30 day trial.

    Is this just laziness on Adobe's part? 32-bit XP has worked well (ehm, well after the 1829-odd service packs) for a long time! I do not want to give Microsoft money for something that gives me no extra value (e.g., Windows 7). Every compiler I've worked with gives an option for 32 bit or 64 bit executables.

    Time to start looking at other options for converting Fuji X-trans raw files.

    Sheeeiiooot.
     
  2. Lawrence A.

    Lawrence A. FujiXspot Veteran

    409
    Jan 31, 2013
    Albuquerque, NM
    I find it annoying too. I had to install it on my Windows 7 laptop, as it could not install it on my XP desktop. I can always plug the HDMI of the laptop into a good monitor, but it's a pain. Has Adobe got stock in Microsoft?
     
  3. the sardonic iconic

    the sardonic iconic FujiXspot Veteran

    218
    Feb 2, 2013
    NYC
    It just makes zero financial sense to support a 13 year old legacy operating system that cannot support the current technology and advancements that these programs utilize.