X10 OVF dust

Discussion in 'Fuji X10, X20, X30, XF1, and X-S1' started by Lachlan, Feb 7, 2013.

  1. Lachlan

    Lachlan FujiXspot Regular

    51
    Feb 7, 2013
    Hello folks,
    I'm looking for feedback.
    I have an X10 with a bit of dust in the viewfinder. Actually, it's more like a couple of dust spots and at least one little hair fragment. This made its way into the viewfinder within two weeks of ownership. I have contacted Fuji and was informed cleaning this out would not be covered under warranty (this is in Canada), and the implication was that it would be costly to remove.
    Alternatively, it was suggested I buy canned air or a CO2 blaster (without propellant of course), and blast air in through the viewfinder on both sides, front and back, wherever I could.
    Is this really a good idea?
    The comment I got was that the dust would blow elsewhere. Where? Onto the sensor?
    Has any one else bothered with this? Is it even worth it? Is there another way?
    Thanks in advance for any advice and/or sharing of experiences with this.

    Lachlan
     
  2. Snix

    Snix FujiXspot Rookie

    16
    Feb 1, 2013
    Australia
    Doesn't sound good, such a product should have such problems. I had dust spots on my Canon S90, they were on the sensor. They fixed it under warranty and I would expect Fuji to do the same. Maybe try and take it higher. The dirt may have already been in there or it is not sealed properly for it to happen so soon...
     
  3. Lachlan

    Lachlan FujiXspot Regular

    51
    Feb 7, 2013
    Thank you

    Thanks kindly. I'll see what I can do.