X100 Off Camera Flash

Discussion in 'Fuji X100, X100S, and X100T' started by JoeLopez, Aug 8, 2017.

  1. JoeLopez

    JoeLopez FujiXspot Regular

    118
    May 18, 2017
    Detroit
    Joe
    When I use a Flash cord on the shoe of my X100 and on any speedlight, including the EF-20, I disable silent mode, Set External Flash to ON and the flash fires every time.

    When I keep the same settings and use a Pocketwizard Plus X on the shoe and a Plus X on my EF-20 (with a PC Sync adapter on the flash shoe), the flash fires when I press the button on the pocketwizard every time. When the PW is on the X100 shoe, it fires sometimes and not everytime.

    Anyone using wireless radio triggers on a X100/S/T care to share the camera settings?

    Thanks.
    Joe
     
    Last edited: Aug 8, 2017
  2. flysurfer

    flysurfer X-Pert

    Feb 1, 2013
    Nuremberg
    Rico Pfirstinger
    I use wireless on my X100F, combining EF-X500 and Metz M400 flash units, because my Godox stuff isn't working with the X100F.

    36567387845_a298483d5c_k. 100F0542 by Rico Pfirstinger, on Flickr

    It works fine, but you need a camera with Fuji's current flash system, so the X100, X100S and X100T are out.

    I hope Godox will update their firmware to fully support the X100 series. I really like their 2.4 GHz system. Great lineup with great value.
     
    • Like Like x 2
    • Wow Wow x 1
  3. KillRamsey

    KillRamsey Super Moderator

    Feb 15, 2013
    Hood River, OR
    Kyle
    I've used Yonguo flashes in the hot shoe of the original X100, and with a Yongnuo remote system. I set it up like you did, and didn't have any misfires I can remember.
     
  4. JoeLopez

    JoeLopez FujiXspot Regular

    118
    May 18, 2017
    Detroit
    Joe
    Thank you. Seems strange, I'd think all I need to do is turn OFF silent mode and turn ON external flash. I'll retry.
     
  5. Matt2134

    Matt2134 New to FujiXspot

    1
    Nov 12, 2017



    They have - I just updated my godox flash and trigger with latest firmware (fiddly but manageable) and it works really well on my X100F
     
    • Like Like x 1